XplornetSUCKS  

Go Back   XplornetSUCKS > Main Category > Xplornet Wireless Tower Forum (Motorola equipment) * (old network) *
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Closed Thread
 
Thread Tools Display Modes
  #1  
Old 02-22-2007, 12:21 AM
xplornetadmin xplornetadmin is offline
Administrator
 
Join Date: Feb 2007
Posts: 585
Smile Welcome to xplornetsucks.com

This is a forum for xplornet customers to gather and post connection issues, email issues, installation, customer support or any other issues.
The purpose is to band together share similiar experiences, problems and hopefully make xplornet stand up and address them, rather than make excuses!

Please Don't post any thing that would make xplornet send me a legal letter to shut the site down, just post facts, use testmy.net for speed tests (larger) so we can benchmark connection speeds.

Thanks for visiting.. If we all help each other we may end up getting what we are paying for and just be happy!

This site is no way affiliated with xplornet.com... and I AM NOT an xplornet.com "admin" just an unhappy
customer

After 3 years with this company.. trying to help with my limited technological abiliies..trying to help customer support resolve wireless issues... xplornet still has'nt gotten anything right they oversell their advertised service and do not deliver what they advertise. Reality is... 600kps for 1.5 MB package/700 for 3 MB sustained download.. no where near "HIGH" speeds in my eyes.. and dont forget those speeds are optimim..... xplornet oversells its capabilities so when more people are on line those speeds drop..


SUE ME!!!
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:50 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.